056E: does_vehicle_exist not working

Status
Not open for further replies.
Joined
Apr 15, 2020
Messages
9
Likes
0
Points
1
Location
Scotland
1
#1
Hi,

I have made this script but it seems like the function 056E: does_vehicle_exist is never true

Code:
{$CLEO}                               
0000: NOP


//-------------MAIN---------------
thread "GREENSHxOOTER"


0AC8: [email protected] = allocate_memory_size 1024
0AD3: [email protected] = format "/opx"

:caricamento
if
    Player.Defined($PLAYER_CHAR)
else_jump @caricamento

:GREENSHOOTER_14
wait 50
    if
        0AB0:   key_pressed 70
    else_jump @GREENSHOOTER_14

    0AB5: store_actor $PLAYER_ACTOR closest_vehicle_to [email protected] closest_ped_to [email protected]
    0AD1: show_formatted_text_highpriority "THIS POINT IS REACHED" time 1000
    if
        056E: does_vehicle_exist [email protected]
    else_jump @GREENSHOOTER_14
    0AD1: show_formatted_text_highpriority "THIS POINT IS NEVER REACHED" time 1000

    Actor.StorePos($PLAYER_ACTOR, [email protected], [email protected], [email protected])
    Car.StorePos([email protected], [email protected], [email protected], [email protected])
    050A: [email protected] = get_distance_between_coords_3d [email protected] [email protected] [email protected] and [email protected] [email protected] [email protected]

jump @GREENSHOOTER_14
Which is the problem?


And if I remove this:

Code:
    if
        056E: does_vehicle_exist [email protected]
    else_jump @GREENSHOOTER_14
The game crashes
 
Last edited:
Status
Not open for further replies.
Top