Help Everything about Samp Functions

xzytro

Well-Known Member
Joined
Apr 1, 2013
Messages
2,297
Likes
1
Points
86
#1
This thread is a bit hard to reach, without a link to that thread you need to search for hours. So i will make this sticky thread which contains only the important informations and files about samp functions from that crowded, grammar-killer thread of styler.
-------------------------------------------------------------------------------------------------------
First of all you need a proper crack, gta_sa.exe.
Now, you need Samp-R1 so that all the mods will work
You also need a good installation of DirectX 9.0
If the cleo plugin doesn't work and your game crashes;
Either install the Microsoft Visual C++
For Windows 7/Vista/Xp x86 32bit
For Windows 7/Vista/Xp x86 64bit
For Windows 8(Under the title "Visual Studio Express 2013")
And the .Net Framework 4.0
Or, if you already have these installations, you need to re-install the CLEO library (CLEO v4.1, not the stupid v4.3)

Now, you also need some required .dll files which should be put inside GTA San Andreas directory. Those files are Vorbis.dll, vorbisFile.dll and vorbisHooked.dll, they load your .asi files and thus your cleo.asi too. Without them your cleo library will not get loaded.

Now for the big prize ! All versions of Samp functions :
Samp Functions v2.3(the only version available for XP users)
Samp Functions v2.4
Samp Functions v2.4
Samp Functions v2.6

Sidenote : If you need to update your SAMP Functions version, you must delete the old version you have, in order to put the newer one. Otherwise the two versions will be in a conflict, and it will crash your game. You need to remove other .cleo files such as movemouse.cleo as well.

I can guarantee the security of the links containing .exe files. You can freely download without any doubts.
 

TheZeRots

Well-Known Member
Joined
Dec 21, 2013
Messages
1,247
Likes
0
Points
86
#2
Just a quick-snip! No one made "How to properly install CLEO and CLEO mods?" Since... well... I spent hours trying to find a patch and fix so CLEO would work properly with all mods... I found it... and, ye I found it. Also, could someone, PLEASE, make SAMP Functions v2.6 for XP users?
 
Joined
Mar 14, 2013
Messages
16
Likes
0
Points
51
#7
Try silent's asi loader.
Put the dlls in your GTA SA folder.
Try first the 1.01 if it crash try the 1.1.
 

springfield

Well-Known Member
Staff member
Joined
Feb 18, 2005
Messages
2,937
Likes
30
Points
98
Website
www.ugbase.eu
10
#9
Just a quick-snip! No one made "How to properly install CLEO and CLEO mods?" Since... well... I spent hours trying to find a patch and fix so CLEO would work properly with all mods... I found it... and, ye I found it. Also, could someone, PLEASE, make SAMP Functions v2.6 for XP users?
Try renaming it to sampfuncs.asi and put it next to your gta_sa.exe.

Don't listen to opcode also, use 4.1, 4.2 is a alpha stage shit and bugged as fucked. As a cleo user you don't need 4.3, or 4.2 it doesn't give you any benefit over 4.1 with wich every script works just fine.
 

Lugi.

Well-Known Member
Joined
Sep 25, 2013
Messages
60
Likes
0
Points
56
#11
Try silent's asi loader.
Put the dlls in your GTA SA folder.
Try first the 1.01 if it crash try the 1.1.
As he said you can try put your sampfunctions 2.6 step by step in windows xp with this method.
Check the silent's asi loader Click Here
Then replace it from your gta sa directory, try use now ASI Loader 1.2 Updated, afterwards inbound of the game try see if the SP 2.6 loads, if it will not work certainly then read what did the "m4nuel3" said before.
 

bizel

New Member
Joined
Feb 3, 2014
Messages
3
Likes
0
Points
1
1
#13
Why are they not open source =(

would like to learn it to change it for another programming language.
 

iAnthony

Moderator
Joined
Nov 15, 2013
Messages
594
Likes
0
Points
66
Website
i.xyin.ws
#14
[quote author="iAnthony"]how to use sampfuncs 2.6 om windows xp? :hm: :hm::hm:
I guess you can't man.[/quote]
I used silent's asi loader and it work :catface: :catface::catface: :megusta: :megusta::megusta:
Only problem is that my version of samp keeps crashing everytime i die :fu: :fu::fu:
 

leysram

Active Member
Joined
Feb 5, 2014
Messages
30
Likes
0
Points
6
5
#15
I cant download the samp functions the link gives me ERROR. HELP PLEASE. :forever_opcode_alone:
 
OP
OP
X

xzytro

Well-Known Member
Joined
Apr 1, 2013
Messages
2,297
Likes
1
Points
86
#16
leysram link said:
I cant download the samp functions the link gives me ERROR. HELP PLEASE. :forever_opcode_alone:
Fixed the samp function links and renewed the cleo library download link, because they removed the v4.1 >.<
 

Zain

Member
Joined
Mar 17, 2014
Messages
14
Likes
0
Points
1
1
#19
for those who still get crashed
https://www.youtube.com/watch?v=p7FLk0BUNaI
 
Top